İyi günler TS ailesi; 😀
Seviyorum burayı böyle giresim geldi olaya 😀
Sorum şu ben USB de Linux kullanıyorum şimdi bu Linux 'ı laptopumda açtığımda saat'i geri kalıyor askıda kalıyor gibi bir durum nedeni nedir ve sorunu nasıl çözerim ?

#TeknoYardım #Linux #bios #KonuDışı

BeğenFavori PaylaşYorum yap

#TeknoYardım #Linux #Windows10
Selamlar, yeni bir ssd aldım, mevcut sistemime takıp linux kurmak istiyorum. Ama bu linux kuracağım ssd'yi windows hiç görmesin, diğer windows kurulu olan ssd'yi de linux hiç görmesin istiyorum. Yani boot ettiğimde diğer ssd'nin kablolarını sökmüş gibi olayım. Bu mümkün müdür? Mümkünse nelere dikkat etmeliyim? Kendim araştırıyorum ama henüz bir şey bulamadım o yüzden burdan da sorayım dedim.

BeğenFavori PaylaşYorum yap
Önceki yorumları gör 4 / 5

Linux'e geri döndüm Mint - Fedora Silverblue - Ubuntu Disco Dingo arasında çok kaldım ama Disco Dingo'yu denemek istiyordum. En son 14.10 sürümünde Ubuntu kullanmıştım, baya güzel, Gnome 3'ün yarattığı sıkıntıların çoğu ortadan kalkmış.

Öneriler için teşekkür ediyorum. 🙂

#Linux #ubuntu #discodingo
#benimmasaüstüm

BeğenFavori PaylaşYorum yap

Linux'e geçiyorum hangi dağıtımı kullanmamı önerirsiniz? (Arch falan kullanabiliyorum, basit bir şey olmasına gerek yok.)

#Linux

BeğenFavori PaylaşYorum yap
Önceki yorumları gör 4 / 17

Boş bir linux 180 mb kullanır 😀 #linux #i3 #scrot #debian

BeğenFavori PaylaşYorum yap
Önceki yorumları gör 17 / 30
  • 3dfx @3dfx

    Anam benim laptop simdi uyandim 😀

  • Eren Hatırnaz @erenhatirnaz

    Hocam "Linux" yerine "GNU/Linux" dersek daha doğru olur.

    • arsenik @sha-2

      Ben sevmiyorum Richard kafasını. Linus kafası bizimkisi. Kod açık olsun felsefe umurumda değil.

    • Eren Hatırnaz @erenhatirnaz

      @sha-2 Teknik olarak da "Linux" demek yanlış hocam. "Linux" işletim sisteminin çekirdeğidir. GNU araçlarıyla birlikte bir işletim sistemini oluştururlar. Debian ise bir GNU/Linux dağıtımıdır. https://www.debian.org/releases/wheezy/ia64/ch01s03.html.en

    • arsenik @sha-2

      @erenhatirnaz Ben yanlış şeyleri tercih ediyorum o zaman siz doğrusunda ısrarlı olabilirsiniz.

    • JohnSmith @johnsmith

      @erenhatirnaz Linux öncelikle işletim sistemidir, çekirdeğine de Linux deniyor problem yok, ama öncelikle işleyim sistemidir.

    • JohnSmith @johnsmith

      @erenhatirnaz Birisi internette yanlış birşey yazmış olabilir, aynı sizin bildiğiniz gibi yanlış biliyor. Bilmemek değil öğrenmemek ayıp demişler. Hep diyorum, 'what is linux' diye google'layın, görürsünüz. Wikiprdia tanımını vereyim: Linux (/ˈlɪnəks/ (About this sound listen) LIN-əks)[9][10] is a family of free and open-source software operating systems built around the Linux kernel.

      Ek: Ben çekirdek değildir demiyorum, aynı zamanda ve hatta öncelikle İşletim Sistemidir diyorum. Ama bazıları sadece çekirdek diyorlar, onlar yanılıyorlar.

    • Eren Hatırnaz @erenhatirnaz

      @johnsmith Sadece bir kişi değil hocam altında bir çok insan aynı şeyleri yazmış. "Linux" çekirdiğinin kaynak kodları burada: https://github.com/torvalds/linux . Bunu nasıl işletim sistemi olarak kullanacaksınız? Linux çekirdeği, GNU araçlarıyla birleştiğinde işletim sistemini oluşturur. Bu nedenle işletim sistemi olana "GNU/Linux", çekirdek olana isa "Linux" denir.

    • JohnSmith @johnsmith

      @erenhatirnaz Peki siz öyle bilin, size aşinalığım olduğu için yazma gereği duymuştum yoksa bana ne. Yani 'linux Kernel' demek size göre 'Kedi Hayvanı' demek gibi bir kullanım. Wikipedia'dan 'Linux Kernel' maddesi: The Linux kernel is an open-source monolithic Unix-like computer operating system kernel. The Linux family of operating systems is based on this kernel and deployed on both traditional computer systems such as personal computers and servers, usually in the form of Linux distributions,...

      'what is linux' diye Google'ladığınızda ilk sayfadan, oradaki sayfa özetlerinden:
      * an open-source operating system modelled on UNIX. (En tepede çıkıyor, Google'In tanımı)
      * Linux (/ˈlɪnəks/ ( listen) LIN-əks) is a family of free and open-source software operating systems built around the Linux kernel. (wikipedia.org)
      * Linux is the best-known and most-used open source operating system (opensource.com)
      * Linux is a free open source operating system (OS) based on UNIX that was created in 1991 by Linus Torvalds. (techopedia.com)

      From smartphones to cars, supercomputers and home appliances, the Linux operating system is everywhere. (Arama sonuçlarında en üstte çıkan linux.com'un ana sayfasında, ilk cümle).

      Bakın https://www.oreilly.com/openbook/debian/book/ch01_02.html Learning Debian GNU/Linux By Bill McCarty 1st Edition September 1999 Kitaptan:
      1.2 What is Linux?
      Linux is an operating system, a software program that controls your computer.

      Ben çekirdek değildir demiyorum, aynı zamanda ve hatta öncelikle İşletim Sistemidir diyorum.

    • Eren Hatırnaz @erenhatirnaz

      @johnsmith Hocam olayı kişiselleştirmeye gerek yok. Wikipedia'daki 'Linux Kernel' maddesinde yazılanlar, benim argümanımı destekliyor. "computer operating system kernel" denişmiş yani bir "sistem çekirdeğidir" denilmiş. "The Linux family of operating systems is based on this kernel" Burada da "Linux ailesindeki işletim sistemleri de, bu kerneli kullanır" denilmiş. "Linux ailesi" yerine "GNU/Linux ailesi" yazması daha doğru olurdu bence. Wikipedia'da yazan her şey de doğrudur anlamına gelmiyor hocam. Diğer kaynaklara gelecek olursak: Hocam "Linux"un tek başına bir işletim sistemi olduğunun sanılması çok sık yapılan bir yanlış ya da yanıltma, artık o kişinin görüşlerine göre değişir. Çünkü GNU projesindeki insanların emeklerini görmezden gelmek isteyen çok insan var camiada. Hocam ben de "Linux işletim sistemi değildir" demiyorum, "işletim sistemi olanın ismi GNU/Linux'dur" diyorum. Kodların olduğu repository linkini yukarıda verdim hocam, buyrun GNU araçları olmadan işletim sistemi olarak kullanmaya çalışın. Popüler siteler yerine şurada yazılanları okumanızı tavsiye ederim hocam: https://www.gnu.org/gnu/gnu-linux-faq.tr.html#why . Konuyu açan arkadaşı fazlasıyla rahatsız ettik, ben şahsen burada noklanıyorum hocam, eğer devam etmek isterseniz profilim üzerindeki web sitesinden e-posta adresime ulaşabilirsiniz, ordan devam ederiz.

    • JohnSmith @johnsmith

      @erenhatirnaz Devam etmeye gerek yok. Özetle GNU tayfasının zavallı bir şekilde kredi kapma kaprisi sonucu tutturduğu birşey. Doğrudur, teknik olarak belli bir seviyeye kadar *tartışmak* mümkündür ama gerçekçi olalım bu kullanımın tutmasına imkan yok. Türkiye'nin kuruluşunda Kürtlerinde payı var, ismi Krt/Türkiye olmalıdır demek gibi bu, hatta süper bir örnek oldu (Eğer bu yorumumu tartışmayı uzatıcı nitelikte bulursanız silebilirsiniz, niyetim devam etmek değil).

  • MH. @mhcycle

    sonra bi chrome açarsın şaşırır kalırsın

  • Ufkabakan @ufkabakan

    Vay arkadaş, ben de Skype tek başına 1.5GB RAM yiyor.

Ubuntu 19.04'ün kod adı "Disco Dingo" olacakmış. 😀

#ubuntu #linux

BeğenFavori PaylaşYorum yap

"Linux on DeX ile artık özel bir Ubuntu 16.04 LTS sürümünü harici ekranlara bağladığınız Galaxy Note 9 ve Galaxy Tab S4 üzerinden kullanabileceksiniz. Linux on DeX beta programı başlıyor."

https://www.donanimhaber.com/Linux-on-DeX-beta-programi-basliyor--104914

#linux #samsung #samsunggalaxynote9 #samsunggalaxytabs4 #linuxondex #donanımhaber

[SDC18] Linux on DeX Will Make It Easier for Developers to Code on the Go

The combination of Samsung DeX and the Linux on DeX app adds new levels of flexibility to developers’ work by allowing them to connect their Galaxy device to...
BeğenFavori PaylaşYorum yap

#Linux bilen sevgili arkadaşlarım, yardımınıza ihtiyacım var. İnternette bakındım ama bir şey bulamadım, bulduklarımı da anlamadım.

Elementary OS kullanıyorum ve birkaç gündür mağaza uygulaması üzerinden güncelleme yaptığımda yapmış gibi yapıp aslında yapmıyordu, güncelleme sonrasında update butonu hala basılabilir oluyordu ve istersem 100 kere aynı güncellemeyi alabiliyordum. Buna çok takılmadım fakat başka bir sorunun göstergesiymiş meğer.

Şimdi mağazadan hiçbir uygulamayı indiremiyorum. Hangi uygulamayı indirmek istersem isteyeyim aşağıdaki hatayı veriyor:

Error while installing package: trying to overwrite '/usr/lib/x86_64-linux-gnu/liblur.so.3.0.3', which is also in package libratbag 0.9.903.0~bionic

Windows olsa sırf "overwrite" kelimesinden hareketle gider /usr/lib/x86_64-linux-gnu/liblur.so.3.0.3 klasörünü silmeyi denerdim ama linux olunca kurcalamaya cesaret edemiyorum bu şekilde 🙁

Çok tatlı bir şekilde kurmuştum sistemi, daha önce de bana 1 aydan fazla dayanmışlığı yoktu, hadi demiştim, Windows'un berbat tasarımını çekmektense son bir şans vereyim ama yine 1 ayı çıkaramadı 🙁

BeğenFavori PaylaşYorum yap
  • Erman @ermanyurdakann

    Ayrıca uygulamaları terminal üzerinden indirmek istediğimde de şununla karşılaşıyorum:

    erman@erman-elementaryjuno:~$ sudo apt-get install gimp
    [sudo] password for erman:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    gimp is already the newest version (2.8.22-1).
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
    libratbag-tools : Depends: lur-command but it is not going to be installed
    Depends: ratbagd
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
    erman@erman-elementaryjuno:~$ apt --fix-broken install
    E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
    E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?
    erman@erman-elementaryjuno:~$

  • Parzival @parzival

    sudo dpkg --configure -a
    sudo apt update

    ya da

    sudo rm -vf /var/lib/apt/lists/*
    sudo apt update

    • Erman @ermanyurdakann

      Bunları uyguladıktan sonra yeniden mi başlatmam lazım? İkisinde de aynı hatayı vermeye devam etti.

    • Parzival @parzival

      @ermanyurdakann Evet yeniden başlatırsanız iyi olur, düzelmezse başka yollara bakmam gerekiyor.

    • Erman @ermanyurdakann

      @parzival Yeniden başlatıp deneyeyim.

    • Erman @ermanyurdakann

      @parzival İşe yaradı 🙂 Yeniden başlattığımda örnekteki gimp ve denediğim birkaç başka program kurulu haldeydi, düzgünce çalışıyorlar şimdi. Başka uygulamalar da indirebiliyorum yeniden. Oh be, kurtardınız beni 😀

    • Parzival @parzival

      @ermanyurdakann Çok iyi sevindim çalışmasına 🙂

    • Erman @ermanyurdakann

      @parzival Bence ikinci verdiğiniz komut işe yaradı, o komuttan sonra en son update deyince baya bir işlem yaptı çünkü, zaten kurulu olan birkaç uygulamayı tekrar yükledi sanırım, o arada bozulmuş eski yüklemeleri de toparladı.

      Linux çok ilginç. Bazen çok zor görünen bir sorun şıp diye bir anda çözülüyor ama nasıl çözüldüğünü anlamıyorum 😀

    • Parzival @parzival

      @ermanyurdakann Linux'te her şey dosya halinde saklandığı için insan aynı dosyada bir sürü değişiklik yapmak zorunda kalıyor. Karışıklık olunca sistemde hatalar olmaya başlıyor. 2. komutla uygulamaların listelendiği dosyayı silince otomatik olarak kendi yeniden oluşturdu.

      Linux dünyasının sevdiğim yanı bu, sorun çözdükçe dilini anlamaya başlıyor insan 😀

    • Erman @ermanyurdakann

      @parzival Şimdi de uninstall çalışmıyor mesela, siliyorum programı, hala orada 😀 autoremove denediğimde yine apt --fix-broken install hatasını aldım. Ama bırakacağım böyle, çalışsın yeter ki. Logitech G300s farenin makro tuşları için falan programlar buldum, bir sürü şeyler ayarladım, Firefox'a userchrome.css ile tema yaptım falan... Bir daha asla uğraşmam bunlarla, o yüzden tamamen bozulana kadar kullanmaya devam edeceğim 😛 Yedek de alıyorum timeshift ile ama yerim çok kısıtlı olduğu için çok eski yedekler yok, en eski yedek bu sorun başladıktan sonraya ait, yani öyle de toparlayamam, o yüzden gittiği kadar gitsin 😀

    • Parzival @parzival

      @ermanyurdakann sudo apt -f install yaptınız mı daha önce?

    • Erman @ermanyurdakann

      @parzival Yapmadım hiç, yapayım mı? Ne yapacak bu?

    • Parzival @parzival

      @ermanyurdakann sudo apt install -f ya da sudo apt -f install bozulan, gerekli olmayan dosyaları siler ve yeni yüklenen bir programın çalışması için gerekli olan dependecy'leri yükler.

    • Erman @ermanyurdakann

      @parzival Böyle dedi.

      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      Correcting dependencies... Done
      The following additional packages will be installed:
      liblur3 lur-command ratbagd
      The following NEW packages will be installed:
      liblur3 lur-command ratbagd
      0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
      2 not fully installed or removed.
      Need to get 0 B/182 kB of archives.
      After this operation, 1.046 kB of additional disk space will be used.
      Do you want to continue? [Y/n] y
      (Reading database ... 187959 files and directories currently installed.)
      Preparing to unpack .../liblur3_0.9.903-1-201809262344~ubuntu18.04.1_amd64.deb ...
      Unpacking liblur3:amd64 (0.9.903-1-201809262344~ubuntu18.04.1) ...
      dpkg: error processing archive /var/cache/apt/archives/liblur3_0.9.903-1-201809262344~ubuntu18.04.1_amd64.deb (--unpack):
      trying to overwrite '/usr/lib/x86_64-linux-gnu/liblur.so.3.0.3', which is also in package libratbag 0.9.903.0~bionic
      Preparing to unpack .../lur-command_0.9.903-1-201809262344~ubuntu18.04.1_amd64.deb ...
      Unpacking lur-command (0.9.903-1-201809262344~ubuntu18.04.1) ...
      dpkg: error processing archive /var/cache/apt/archives/lur-command_0.9.903-1-201809262344~ubuntu18.04.1_amd64.deb (--unpack):
      trying to overwrite '/usr/bin/lur-command', which is also in package libratbag 0.9.903.0~bionic
      Preparing to unpack .../ratbagd_0.9.903-1-201809262344~ubuntu18.04.1_amd64.deb ...
      Unpacking ratbagd (0.9.903-1-201809262344~ubuntu18.04.1) ...
      dpkg: error processing archive /var/cache/apt/archives/ratbagd_0.9.903-1-201809262344~ubuntu18.04.1_amd64.deb (--unpack):
      trying to overwrite '/lib/systemd/system/ratbagd.service', which is also in package libratbag 0.9.903.0~bionic
      dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
      Errors were encountered while processing:
      /var/cache/apt/archives/liblur3_0.9.903-1-201809262344~ubuntu18.04.1_amd64.deb
      /var/cache/apt/archives/lur-command_0.9.903-1-201809262344~ubuntu18.04.1_amd64.deb
      /var/cache/apt/archives/ratbagd_0.9.903-1-201809262344~ubuntu18.04.1_amd64.deb
      E: Sub-process /usr/bin/dpkg returned an error code (1)

    • Parzival @parzival

      @ermanyurdakann Hocam büyük ihtimalle sizin PPA kullanarak veya .deb kullanarak yüklediğiniz programların doğru çalışması için gerekli olan paketler yüklenmiyor. Broken Package hatası olduğu için sistem sorun yaşıyor. Çalışıyorsa daha fazla uğraşmamak daha iyi dediğiniz gibi yoksa nereye gideceği belli değil şuan.

    • Erman @ermanyurdakann

      @parzival 🙁 Temelde ihtiyaç duyacağım her şey kurulu sayılır, yeni bir program kurmadan olduğu haliyle kullanacağım öyleyse. Linux'ta sevmediğim tek şey bu işte, bir yerde bir hata yaptığım zaman o hatayı tespit edemiyorum, bu yüzden şimdi format atıp yeniden kursam bile aynı hatayı yine yaparım muhtemelen.

      Kim bilir bu sefer ne yaptım da bozdum 😀

    • Parzival @parzival

      @ermanyurdakann En iyisi çalıştığı sürece yola devam etmek 😀

  • Osman Öztürk @ptseeker

    @ermanyurdakann Bir daha böyle bir sorun yaşarsanız synaptic packet managerdan da düzeltebilirsiniz diye düşünüyorum

BeğenFavori Paylaş